Sunday, August 9, 2009

WebKit Version

A missing feature of the QtWebKit API has been the ability to determine what version of WebKit you currently had. While you could parse it out of the user agent that was clumsy and in fact the version number in the user agent was hard coded into QtWebKit (and out of date!). Recently Robert Hogan wrote a patch for QtWebKit that not only properly determines the WebKit version, but also adds new API to QtWebKit to determine the values. This API will be part of Qt 4.6 and when building with WebKit trunk (and 4.6 once Qt master's copy of webkit is synced) Arora will show the current WebKit version in the about dialog.

No comments: